RaspberryPI 3 Woes

This goes into the category of “DON’T TRY THIS AT HOME!” but read on if you don’t mind the length.

Yesterday, my son got a RaspberryPI 3 all set up as a server running Dietpi as the OS with mpd, myMPD, NextCloud, and ProFTP installed and running. It was awesome. After getting all the software installed, he noticed that although everything seemed to run snappy and resource usage looked good, the heat started to build up. First I encouraged him to take off the cover from his case. He found a small desk fan that he leaned over the top of the case which cooled it down nicely, but looked like it could easily fall over at any moment.

When I got home last night I remembered that I had 8 case fans from an old project I did 12 years ago where it was cheaper to buy 10 fans than to buy 1 or 2. I said, “Maybe you could research to see if you can use one of these case fans hooked up to the GPIO of the RaspberryPI and use that as a more permanent solution. I don’t care if you ruin the fan when you rewire it there are still 7 more.”

Then my son realized that if he used some jumper wires from his electronics kit he could hook up the fan right away. I did say, “Oh, I noticed these fans are 12V and the RaspberryPI runs on a 5V power supply so maybe this won’t work.” But then we decided that the fan would just turn at a lower speed because of less power, so he hooked it up, the fan started turning plenty fast as you can see from the picture, but when he rebooted, the PI it didn’t boot back up. He disconnected the fan, and the PI rebooted and everything worked again, so he thought he didn’t wait long enough. He shutdown and reconnected the fan, and the PI didn’t boot. Disconnected the fan, and the PI didn’t boot at all the fourth time.

Those of you who understand electricity better than us, probably realize what happened. We think (after doing some research which we should have done first) hooking up the 12V fan to the GPIO which outputs only 3.3V probably fried one of the fuses on the PI 3 so now we have a dead PI 3.

  • If you think we can salvage this PI 3 let me know how we can?

  • If you have some PI 3’s because you have replaced all of your 3’s with 4’s and would like to donate one to our cause let me know?

  • Otherwise let this be a lesson to learn a little more about electronics before you try what you think will be an awesome idea.

We do have a plan B. I found some old unused wall warts that are DC 12V power supplies for old electronics we don’t have any longer. We are planning to learn to wire one of these to the case fan so it has a separate power supply from the RaspberryPI in the future.

This pic was taken when we both thought this was the best idea ever.

Leave it sit unplugged for a day or two then try booting it (without the fan). If you are really lucky the polyfuse will reset.

Thanks Ken, we will give that a try. We tried putting it in the freezer last night, but this morning it didn’t boot up even with a fresh install of Dietpi. But we will just leave it alone for a few days and try one more time. It doesn’t look good though. :slight_smile:

If you want to and have the cash about 12 pounds UK (with shipping) Pimoroni sell this, which as the Pi4 needs a cooling solution I bought, it works great and installs easy

Thanks @TonyHughes for the kit idea, but I have an exciting update.

Apparently, we didn’t kill the RaspberryPI 3, it lives! My son had one RaspberryPI 3+ that he had Ubuntu Mate installed on and was using as a programing desktop. Since, he missed all of the server apps that were running on the PI 3 that we thought was dead, he decided to take the SD card from that one and put it into his PI 3+. His PI 3+ that was just running Ubuntu Mate, failed to boot with the Dietpi OS SD card. So then we thought perhaps just the SD card got corrupted during booting because we were pulling too many amps with our 12V fan hooked up.

Of course, why didn’t we consider this from the beginning? Actually, that was the first thing we checked, but when we re-imaged Dietpi onto another SD card the RPI 3 still did not boot. We fixed the SD issue by doing the following steps:

  1. Using GParted we deleted all the created partions on the SD card.
  2. Using GParted we reformatted the SD card using the Fat32 file system (in the hopes that this would restore it to how it came from the manufacturer).
  3. Re-imaged Dietpi OS onto the SD card using Rosa Image Writer.

In the past when we though the SD card got corrupted, we would just re-image the Raspberry PI OS onto the SD card assuming this would delete all of the data on the SD card, but apparently that doesn’t always work. We thought that we had ruined a 1st generation Raspberry PI 1B too when an update of Dietpi seemed to fail, and re-imaging the SD card failed to fix the issue. But when we followed the above steps and tried booting our oldest Raspberry PI 1B it came back to life too. So now we have all 4 of our Raspberry PI’s working again, two RPI 1B’s, one RPI 3B (we don’t think the HDMI port is working though so running headless as a server), one RPI 3B+.

I guess the lesson here is that SD cards can become corrupted easily, and simply re-imaging the OS onto the SD card is not a good way to test whether the RPI or the SD card is the problem. By the way, we have been using only the SanDisk recommended SD cards with our RPI’s.

3 Likes

I had a similar experience with my Pi-hole Raspberry Pi Zero W. After running updates on it I decided to reboot. That was the end of it. It never came back up. The RPi0W only cost me $5 so I wasn’t too upset about it. I pulled the micro SD card out and checked it in my PC. All of the files looked like they were still there so I figured I wouldn’t need to re-install and configure the Pi-hole software again. I’d just get a new RPi0W and put the old card in and be done. The next day I went to Micro Center and picked up a replacement RPi0W and a bunch of other stuff I needed. When I got home I put my old micro SD card in the new RPi0W but that one wouldn’t boot either. I downloaded a fresh copy of Rasbpian Buster lite and put it on a new micro SD card, put that in the old RPi0W and it came right up. At first I was happy that my old RPi0W is still working. Then I realized the micro SD card cost more than the RPi0W did, and I still had to re-install and configure Pi-hole again.

1 Like

@Ken.F I’m curious if you tried the steps that I outlined above, if you could get the old SD card working again. When everything happened 4 days ago, we had re-imaged a different SD card with Dietpi and tried booting that too, but it didn’t work, the RPI 3 still seemed to be dead. Then we took that SD card and put it into my son’s new phone for extra storage, and it worked just fine in the phone, so we never suspected that the SD card was the cause of the issue.

However, it seems that during the boot process that a RPI can damage an SD in such a way that it is usable in other devices, readable in other devices, but useless to RPI’s. For whatever, reason the steps I outlined above have revived 2 SD cards and the RPI’s that are booting them.

Thanks for responding @Ken.F it is good to know that a fellow community member has had similar issues with their RPI’s. I will say, having such a low powered device running Nextcloud, Gitea, ProFTP, and other services is so much fun. It is like building your own internet filled with cloud services that you control completely. Now if we can just keep our SD cards from becoming corrupted on reboots and system updates that would be great :smile:

I might be able to get the old card working again but In my experience micro SD cards can’t be trusted once they become corrupt. It’s a pretty good sign the card is going bad. I don’t mind trying to use those cards for LibreELEC since it’s easy to make backups using the built in backup tool, but I don’t trust them for anything important.

Good point, although nothing that we are doing on the RPI’s is mission critical or work related just home computing fun and experimentation.

The SD cards that have been “corrupted” by the system updates on our RPI’s or by our fan experiment are mostly newer cards with very few read/writes on the cards, few hours of usage, and they are higher quality SanDisk SD cards. It seems to be related more to how the RPI’s boot than the SD cards themselves. Like you mentioned before since the cost of an SD is almost or equal to the cost or worth of the RPI’s that we are using them on, it doesn’t make a whole lot of sense to keep buying new SD cards every time one of the RPI’s corrupts one on boot up unless…

Like you, you were depending on your RPI and the SD booting in it for an essential service it would be best to buy a new SD to eliminate possible future issues.

I will be interested in seeing if my son has issues with the SD that wouldn’t boot in the RPI but seems to be working in his phone. He won’t be saving anything irreplaceable on that SD in his phone, but if it fails after a few weeks or months of use, then we know that the SD cards are truly getting damaged by their use in the RPI’s.

Thanks for mentioning LibreELEC too @Ken.F, we should really hook up one of the RPI’s to our TV and give that a try. It might be a fun experiment.

LibreELEC is a great OS to run Kodi on a Raspberry Pi. Unfortunately Kodi got raked over the coals by the press for being piracy software a few years ago. Kodi is 100% open source and legal out of the box but there are some guides you may find on the internet that can lead you to adding media sources you may want to avoid. If you stick with the add-ons available in the official Kodi and LibreELEC repositories you won’t have anything to worry about. If you are following along in some online how-to article or video and it tells you to enable unknown sources and manually type in a repository url you are on your own.

Be sure to check out the LibreELEC and Kodi Wikis and forums. They are great resources.

https://kodi.wiki/view/Main_Page
https://forum.kodi.tv
https://libreelec.wiki

^^^^ I don’t know why the LibreELEC forum link formatted itself that way. I didn’t do that. Weird.

I watched a YouTube video the other day and someone did extreme testing of the SD card with the new Pi 4 to see if some of the old issues of cards getting corrupted were still an issue on a Pi4 and he could not get the card to corrupt whatever he tried. for the life of me I can’t remember who it was by.

@TonyHughes if you look through your YouTube history, can you spot it in there? I would be interested in seeing that. We are kind of waiting to see if there is a hardware revision that comes out in the next few months for the Pi4. We are planning on getting one and running our servers on that, but with the heat issues, the USB-C issues, we are kind of waiting for version 2 to come out and hoping that will be even less buggy. I really do believe that our SD corruption is more about the Pi’s and less about the SD’s themselves. Last night we had the SD corrupt again on the Pi3, so we ordered two new SanDisk Ultra 16gig SD cards and Amazon delivered them already today, so he is trying to reinstall Dietpi on one of those and get things up and going again.

I used Etcher to write a new image on the old micro SD card today. I didn’t do anything to prepare it. I just stuck it in my card reader, backed up the files I wanted to keep and let Etcher do it’s magic. It seems to be working OK but I still don’t trust it for anything important.

I’ve just through my regular you tube account and can’t find it but as I have been away there is no guarantee that I was logged in at the time of watching the video, I can’t even remember if I followed a link on another channel. If I do find it again I will post a link for you. Sorry I can’t help at the moment.