LMDE4 Debbie - March 28 and April 04

The next distro challenge, voted for by the BDLL community, is Linux Mint Debian Edition 4 - aka LMDE4.

Its goal is to ensure Linux Mint would be able to continue to deliver the same user experience, and how much work would be involved, if Ubuntu was ever to disappear.

LMDE is also one of the Mint team development targets, to guarantee the software they develop is compatible outside of Ubuntu.

LMDE aims to be as similar as possible to Linux Mint, but without using Ubuntu. The package base uses Debian 10 Buster, instead and Cinnamon 4.4 for its desktop environment.

Download LMDE4

1 Like

This has installed and is working perfectly on my i5 Lenovo Laptop and my newer Threadripper with nvidia 2080Ti.

They have an nvidia option on the live usb that takes care of that and everything installed fine and is working ok on the default 4.19.0-8 kernel.

Everything installed flawlessly, with ETS2 playing without a single micro stutter… if only my other Debian based distro MX Linux could do this.

World of Warships also works well.

If the experience continues to be so good… who knows - it may even replace MX but those are huge shoes to fill.

Regards Zeb…

ASUS Prime X399-A | AMD Ryzen™ Threadripper 2950X Processor | 64GB Corsair VENGEANCE RGB DDR4 3000MHz |Palit GeForce RTX™ 2080 Ti GamingPro |2 x Acer H277HKsmipuz 27" 4K UHD LED Monitor | 1 x AOC U3477PQU 34" Ultra Wide UHD Monitor | Samsung 970 PRo Plus NVMe M.2 1Tb

2 Likes

I’ve had LMDE since the beta was released, but I’ve re-installed the final version on 2 laptops. I like it, as Zeb says it installs easily, just works, everything I need is there, as it should be being based on Debian Buster.

I look at it as Debian with polish applied, ideal for someone who wants Debian Stable but wants a bit more “style” so they don’t have to tweak so much with themes, wallpapers. They just want an out of the box and works experience that looks professional.

I like Debian, I could live with Debian, I would (and have, however “tarted it up” so it looks nicer, with LMDE I didn’t feel the need to, so I would use it over “basic” Debian, OK, I use MX-19 as my daily driver and would pick that over LMDE, but that’s me, it has polish plus a few more bells and whistles (the MX Tools) but there’s nothing wrong with LMDE and the “Mint” in the name may be more familiar to many and so preferred. Given a LMDE machine to use for a work computer I’d be more than happy to use it.

Hardware used :

  • Beta - Lenovo X230 (i5-3320, 8GB RAM, 160GB partition on a Crucial 1TB SSD, 12" 1366x768 display, Intel graphics)
  • Release - HP Elitebook 8470p (i5-3320, 8GB RAM, 160GB partition on Vaseky 480GB SSD, 14" 1366x768 display, Intel Graphics)
  • Release - Dell Latitude E6510 (i5-540M, 8GB RAM, 250GB Crucial SSD, 15" 1600x900 display, NVIDIA® NVS 3100M 512MB gDDR3 / Intel® HD Graphics - I don’t game so it defaults to the Nouveau drivers)

It won’t be replacing MX-19 for me any time soon, but is has joined my (ever growing) list of "I like it, it just works, I could live with this) distros.

OK, one thing, with the Beta I lived with the Cinnamon desktop, but after a day on the release I was missing my preferred Xfce so I installed that, configured it to my “normal” layout - it worked just fine, no problems and I know how to “drive” it. I could have kept Cinnamon, I may even have got to like it, it’s not difficult, I just feel happier with Xfce.

1 Like

No PPA support is a shame. It makes it tough for me to use. I also really dislike their version of apt. It was very nice to get back on Cinnamon.

1 Like

When you say “their version of apt”, do you mean the GUI “Software Manager” or are you literally talking about the “apt” command from Debian?

I mean the command line. From what i can tell, Mint maps (or aliases?) the apt command to aptitude instead of actual apt. If I try using an apt search for example, if it doesn’t recognize the command it returns:

aptitude: unrecognized action '--names-only'
aptitude 0.8.11

Interesting… that does not seem to be the case for me:

john@lmde-test:~$ apt search fprint
i   fprint-demo                                    - simple GTK+ testing libfprint's functions               
p   fprint-demo:i386                               - simple GTK+ testing libfprint's functions               
i   fprintd                                        - D-Bus daemon for fingerprint reader access                 
p   fprintd:i386                                   - D-Bus daemon for fingerprint reader access              
i   fprintd-doc                                    - development documentation for fprintd                   
p   libfprint-dev                                  - async fingerprint library of fprint project, development
...

Oddly, my apt is in /usr/local which is weird… I didn’t explicitly install it or anything…

john@lmde-test:~$ which apt
/usr/local/bin/apt

Try running this and see if you get the same output as I do. If you don’t, something is wrong with one of our systems.

apt search --names-only fprint

Same as you. So the one in /usr/local is the alias to aptitude. If I run the same command with /usr/bin/apt it runs correctly. Seems odd they would do that doesn’t it?

-John

1 Like