Laptop will not post

For those who are unfamiliar with this issue, here’s the run down:

I have a laptop from Dell with:

  • Intel Core i5 (3rd or 4th Gen. Don’t remember exactly) dual-core with Hyper-threading, 2.4 Ghz
  • 8GB DDR3 RAM
  • 750GB 5000RPM HDD from Seagate
  • 1366 x 768 Display
  • DVD Drive

During our Solus 4.1 Fortitude distro challenge, I tried putting Solus on this laptop. Installation went fine. But now, this laptop will barely POST. Whenever I turn it on, it will get to the POST screen, the progress bar fills, then one of three things happens:

  • The entire device freezes with the POST screen still up
  • The POST screen is half-way removed from the screen and then it freezes
  • The entire screen goes black and nothing happens.

I cannot boot from the HDD, a USB drive, or even get into the UEFI settings.

I have tried:

  • Booting with no bootable devices attached
  • Clearing CMOS
  • Clearing NVRAM
  • Clearing RAM
  • Booting with an external monitor attached

I cannot figure out anything else to do. Everything returned the exact same results. Help please?

P.S.
If we can’t get this working it’s fine. It’s just the laptop I use for testing distros. As a last resort I can use it for parts. But getting it working again is ideal.

Thanks for the help!

Did you search using your Dell Service Tag number? There may be some specifics to-do’s for that model.

I did not cause I don’t have one. This laptop was a gift.

No label on the bottom of the laptop?

This might help: https://www.dell.com/support/article/us/en/04/sln151805/how-to-troubleshoot-a-no-post-issue-on-a-dell-notebook-pc?lang=en

There are but the only one that likely would have had it on it is a Refurbishment sticker. I checked the website you linked but most of it doesn’t really help. :-/

This thread sounds similar to your problem. Though there was no resolution posted either good or bad after they ordered a new MoBo. I get a bit annoyed when people do that. Also I’m curious whether you tried getting into the bios with an external keyboard??
https://www.dell.com/community/Laptops-General-Read-Only/Dell-Latitude-E6400-intermittently-no-video-and-chaotic-POST/m-p/5141120

I have not tried that. I will try it next time I get a chance. Although, to be honest, I don’t expect much of a difference. It detects the keyboard is working (I get a notification on the screen saying it’s going to the menu I ask for), just doesn’t do anything.