High Ping

I have been noticing pings about 100-300+ ms with almost nothing running. Normally I have xonotic and nextcloud running with nothing else in memory BUT I have turned off and DISABLED both of them for diagnostic purposes and the results below are with them both off.

 derek  Mulder  ~  $  inxi -Fxxxza 
System:    Host: Mulder Kernel: 5.3.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=303163f8-4186-4a13-a540-3c317dd1f6b2 rw quiet splash 
           Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 wm: kwin_x11 dm: LightDM, SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Acer product: Aspire ZC-700G v: N/A serial: <filter> Chassis: type: 13 serial: <filter> 
           Mobo: Acer model: IPMBW-BR v: 1.04 serial: <filter> UEFI: American Megatrends v: R01-B2 date: 01/28/2016 
CPU:       Topology: Quad Core model: Intel Celeron N3150 bits: 64 type: MCP arch: Airmont family: 6 model-id: 4C (76) 
           stepping: 3 microcode: 368 L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12805 
           Speed: 969 MHz min/max: 480/2080 MHz Core speeds (MHz): 1: 660 2: 1187 3: 787 4: 825 
           Vulnerabilities: Type: l1tf status: Not affected 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass status: Not affected 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
Graphics:  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics 
           vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:22b1 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell) v: 4.5 Mesa 19.1.4 compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio 
           vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:2284 
           Sound Server: ALSA v: k5.3.0-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8168 
           v: 8.047.02-NAPI port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 bus ID: 03:00.0 chip ID: 8086:095a 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 465.76 GiB used: 82.35 GiB (17.7%) 
           ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
Partition: ID-1: / raw size: 465.47 GiB size: 457.16 GiB (98.22%) used: 82.35 GiB (18.0%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 187 Uptime: 45m Memory: 3.76 GiB used: 1.77 GiB (47.1%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           clang: 8.0.1 Shell: bash v: 5.0.7 running in: yakuake inxi: 3.0.35 

derek  Skinner  SSH  ~  $  ping mulder
PING Mulder (10.0.0.253) 56(84) bytes of data.
64 bytes from Mulder (10.0.0.253): icmp_seq=1 ttl=64 time=4.12 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=2 ttl=64 time=1543 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=3 ttl=64 time=537 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=4 ttl=64 time=149 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=5 ttl=64 time=991 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=6 ttl=64 time=3.78 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=7 ttl=64 time=9.79 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=8 ttl=64 time=441 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=9 ttl=64 time=66.6 ms
64 bytes from Mulder (10.0.0.253): icmp_seq=10 ttl=64 time=288 ms
^C
--- Mulder ping statistics ---
10 packets transmitted, 10 received, 0% packet loss, time 23ms
rtt min/avg/max/mdev = 3.782/403.355/1542.958/482.519 ms, pipe 2
 derek  Skinner  SSH  ~  $  

Not sure I understand the setup but this is only between machines? What about pinging the router/firewall/whatever?
If it’s wifi there might be interference from other access points maybe but that should change if you move?

2 out of 3 boxes are ok, one is wired, other is wireless. The 3rd box is wireless 5 ghz and seeing high pings.

I’d try 2.4GHz to see if there’s a difference. I’ve got the same card in a china laptop and I’ve seen multiple issues with it when searching for answers. I got mine working well on 2.4GHz and then forgot about it since I just assumed my access point and and that card didn’t play well with each other.
It didn’t work at all on 5GHz on an older kernel (I think it was Ubuntu) but worked well on Arch. That was like 6+ months ago though so I guess that might have been solved.

Error messages in dmesg might also reveal something that might help you.

already tried that too :frowning: