Cannot Play CBS DRM content

I was trying to watch some tv episodes off of cbs.com and the starting commerical would play then once that was done the show would not start. I tried to use brave, firefox, and google chrome and none of them worked. Anyone having any way to get DRM content to work in those browsers? I did make the option to play protected content was enabled in all the browsers as well.

I guess you need an account to view any of the content which I don’t :neutral_face:

it is not an account issue. I signed up for the free trail and it still did not work. Tried it via amazon prime and it worked fine. Perhaps the player that cbs uses not sure.

This seems to be a recent development. I have used CBS all access in the not too distant past. What’s interesting is I even tried different user agents in the browser and still no joy. I will keep digging as I would like to have it back too.

I’m sorry if I didn’t make myself clear. I was not saying it was an account issue for you. I was just saying that I was going to verify it but you need to create an account which is something I didn’t want to do.

:slight_smile:

I guess this now works? I don’t use it but just saw the Ars news and remembered this thread :stuck_out_tongue:

Update, January 31 : After this story went live earlier in the week, an Ars reader reached out to speculate that the problem was most likely due to enabling VMP (Verified Media Path) on CBSi’s Widevine server. Verified Media Path, similarly to UEFI Secure Boot, makes certain that content will only be delivered to browsers with sanctioned, verifiable “authentic” framework; this is a configurable behavior, and by default, unverified platforms are allowed to receive licenses.

This morning we asked CBSi executives to check with their engineers and see if this was the problem. While we never received a response, two hours later, CBS All Access was playing successfully on Google Chrome on multiple Linux distributions. (Firefox still crashes.) For now, we have verified that the fix—which, again, may or may not actually have involved VMP—covers all of CBS’ content and not merely the first episode of Picard, which CBS released yesterday on YouTube for a limited time. If we hear official word from CBS regarding what happened behind the scenes, we’ll update this post accordingly. The original story appears unchanged below.

Interestingly I just received the following email from support.


Dear Dan,

Thank you for contacting CBS All Access. We do apologize for any inconvenience you may have experienced. We see that you are using a Linux computer in order to stream from CBS.com. Please be advised that we do not currently support this operating system. If you would like to stream from a desktop/laptop computer, we ask that you do so from a machine running either of the following operating systems:

1. Windows 7 (32 or 64 bit)
2. Windows 10
3. Mac OS X v10.6 or later

For a full list of dekstop/laptop compatibility requirements, please click here [https://cbsi.secure.force.com/CBSi/articles/FAQ/What-are-the-minimum-system-requirements-for-CBS-All-Access?retURL=%2FCBSi%2Fapex%2FKnowledgeHome&popup=false&faqTitle=What+are+the+minimum+system+requirements+for+CBS+All+Access%3F&referer=cbs.com%2Faa&template=template_aa17]. We understand how frustrating this may be, and apologize for the inconvenience! Please know that as we move forward, we plan on expanding out to more streaming devices. Stay tuned for further updates!

Thanks so much, and I look forward to helping you further!

Regards,
CBS All Access Customer Service

i can confirm that the videos do play now

1 Like